Contacting SSO from external visual studio DEV

Mar 29, 2016 at 1:31 PM
This is about the Get SSO config functoid.

In my dev-environment we only use Visual Studio to develop our BizTalk solutions and then push them to our actual server that hosts our BizTalk solutions.
Since all the config-data for SSO is placed in the Active SSO-server that runs together with BizTalk on the BizTalk-server a Connection between our dev-environment and the Active SSO server needs to be made to be able to test maps etc. that actually try to get SSO-data.
I have tried to change the SSO-server via ssomanage.exe but when I test the map I get this error:

An error occurred during a call to extension function 'SSORead'. See InnerException for a complete description of the error. Could not contact the SSO server ''. Check that SSO is configured and that the SSO service is running on that server.
(RPC: 0x800706D9: There are no more endpoints available from the endpoint mapper.)

If I import the solution to the Biztalk-server and do a test on Visual Studio that is installed there it works as it should. So from what I can see there seem to be some kind of Connection issue between my dev-environment and the SSO-server.

Anyone got an idea of what to do?


p.s. if I run SSOmanage.exe -showserver on both our Machines (host and dev-env) I get the same sso:server so our dev-env. is configured to run the same SSO-server as the actual host-server. Just seems to be some kind of block somewhere that blocks us.